Error: file /boot/grub/i386-pc/normal.mod" NOT FOUND

Chiuso
Knowing
Posti
24
Data di registrazione
lunedì 19 gennaio 2015
Stato
Membri
Ultimo intervento
venerdì 27 novembre 2015
- 24 mar 2015 alle 16:30
Noureddine Bouzidi
Posti
22674
Data di registrazione
giovedì 19 marzo 2009
Stato
Moderatore
Ultimo intervento
giovedì 7 gennaio 2021
- 11 mag 2015 alle 14:25
Improvvisamente, senza che abbia fatto alcunchè, Xubuntu 14.04.2 non si avvia e mi appare la scritta "Error: file /boot/grub/i386-pc/normal.mod" NOT FOUND...grub rescue>". Non ho dual boot. L'HD, alla verifica, sembra perfettamente a posto. Non ho mai messo mano al contenuto dei files Grub.
Ho subito provato con una live di Xubuntu (utilizzata per l'installazione) se a quell'indirizzo ci fosse o meno "normal.mod" e... montato l'HD, nella finestra non è apparso nulla di nulla. Cambiata live, con Lubuntu, la finestra invece mostrava due cartelle di cui una contenente tutte le cartelle del sistema operativo dello stesso disco, COMPRESO "normal. mod" al suo posto (l'ho pure aperto con Leafpad). Ho ripetuto più volte questa prova con le due lives.
Dopo tre giorni di inutili ricerche sul Web, chiedo aiuto, dato che le moltissime indicazioni trovate non mi sono state di alcuna utilità, anche perché non è possibile scrivere nemmeno 'grub-update' dopo la scritta di cui sopra. Grazie.
Potrebbe anche interessarti:

1 risposta

Noureddine Bouzidi
Posti
22674
Data di registrazione
giovedì 19 marzo 2009
Stato
Moderatore
Ultimo intervento
giovedì 7 gennaio 2021
15.424
24 mar 2015 alle 17:13
ciao,
il computer è nuovo? usa EFI secure boot invece del normale BIOS ?
0
Knowing
Posti
24
Data di registrazione
lunedì 19 gennaio 2015
Stato
Membri
Ultimo intervento
venerdì 27 novembre 2015
1
24 mar 2015 alle 19:02
Il computer non è nuovo e accedo al BIOS. Debbo correggere un piccolo particolare: non vedevo nulla nella finestra con una delle lives perché non avevo attivato 'rendi visibili i files nascosti'. Ho tentato di dare questi comandi trovati in uno dei tanti siti che parlano del problema, ma credo di aver peggiorato la situazione; ora non mi appare più "error: .... grub rescue>" ma semplicemente 'grub>' e quindi sono al punto di prima: 1)mount /dev/sdb1 /mnt 2)grub-install --root-directpry=/mnt /dev/sdb . Ma l'ultimo comando (update-grub) non c'è verso di attivarlo...
0
Noureddine Bouzidi
Posti
22674
Data di registrazione
giovedì 19 marzo 2009
Stato
Moderatore
Ultimo intervento
giovedì 7 gennaio 2021
15.424
25 mar 2015 alle 14:42
ti conviene reinstallare grub (Grub-install) invece di update grub
dai un'ochiata a questa guida https://askubuntu.com/questions/88384/how-can-i-repair-grub-how-to-get-ubuntu-back-after-installing-windows#88432
0
Knowing
Posti
24
Data di registrazione
lunedì 19 gennaio 2015
Stato
Membri
Ultimo intervento
venerdì 27 novembre 2015
1 > Noureddine Bouzidi
Posti
22674
Data di registrazione
giovedì 19 marzo 2009
Stato
Moderatore
Ultimo intervento
giovedì 7 gennaio 2021

8 mag 2015 alle 23:05
Credo si tratti di un gigantesco BUG di Xubuntu. Un'installazione perfettamente funzionante su HD, non può andare in malora solo perché si utilizza un SO live. Quell'odiosa scritta bianca su fondo nero("Grub rescue") mi è apparsa negli anni decine di volte e MAI sono riuscito a trovare una soluzione a questo problema. Possibile che non ci sia qualcuno che dica: "si scrive questo e questo dopo il '>' lampeggiante"...!? Purtroppo i "normali" utenti Linux non sono ingegneri informatici e non è possibile torturare le meningi per ogni piccolo problema cercando tra mille pagine scritte davvero in modo inconcepibilmente evasivo. Sono sicuro che esiste qualcuno che CONOSCE la soluzione e va dritto alla sua attuazione, senza troppi "forse" e "mi pare", senza nulla togliere alla loro buona volontà.
0
Knowing
Posti
24
Data di registrazione
lunedì 19 gennaio 2015
Stato
Membri
Ultimo intervento
venerdì 27 novembre 2015
1
25 mar 2015 alle 16:55
OK; ci provo... Grazie del suggerimento.
0
Noureddine Bouzidi
Posti
22674
Data di registrazione
giovedì 19 marzo 2009
Stato
Moderatore
Ultimo intervento
giovedì 7 gennaio 2021
15.424 > Knowing
Posti
24
Data di registrazione
lunedì 19 gennaio 2015
Stato
Membri
Ultimo intervento
venerdì 27 novembre 2015

11 mag 2015 alle 14:25
facci sapere!
0