Mancata connessione bluetooth RFCOMM protocollo TDI [Chiuso]

gbgallo 1 Posti venerdì 12 settembre 2014Data di registrazione mercoledì 5 novembre 2014 Ultimo intervento - 5 nov 2014 alle 11:46 - Ultima risposta: n00r 22871 Posti giovedì 19 marzo 2009Data di registrazioneContribuenteStato venerdì 29 dicembre 2017 Ultimo intervento
- 5 nov 2014 alle 17:27
Buon giorno a tutti
Mi chiamo Gianni vivo ad Olbia ed ho esperienza in campo elettronico ed una conoscenza di base dell'informatica.
Ho un problema di connessione con un modulo bluetooth che viene regolarmente riconosciuto na non c'p verso di farlo connettere.
Da una ricerca effettuata ormai sono convinto che sia un problema di protocolli e/o di driver
Infatti nelle proprietà del modulo bluetooth alla voce "posizione" indica:"RFCOMM protocollo TDI"
Poichè questo tipo di protocollo non è riportato tra i protocolli del dispositivo Master cosa devo fare?
Inoltre poichè serve stabilire la comunicazione con un dispositivo smartphone Huawei y300 che3 utilizza protocollo EDR e A2DP probabilmente sono protocolli differenti per cui è ovvio che non si connettano. Quindi la mia domanda è: E' un problema di hardware, nel senso che ho sbagliato l'acquisto del modulo bluetooth o deve installare dei driver specifici per stabilire la connessione?
TKS a tutti Gianni
Altro... 

4 risposte

n00r 22871 Posti giovedì 19 marzo 2009Data di registrazioneContribuenteStato venerdì 29 dicembre 2017 Ultimo intervento - 5 nov 2014 alle 12:39
0
Grazie
ciao,

se ho capito bene: hai acquistato un dongle bluetooth (USB?) tramite il quale vorresti collegare il computer (che sistema gira?) al cellulare Huawei per trasferire file. giusto?
il dispositivo bluetooth e munito di un CD di installazione (driver + programma per gestire i dispositivi)?

dici che viene riconosciuto! hai abbinati entrambi i dispositivi con un codice ?
hai attivati i diversi servizi bluetooth in particolare il servizio OBEX?
hai provato con un altro dispositivo ?
gbgallo1 2 Posti mercoledì 5 novembre 2014Data di registrazione mercoledì 5 novembre 2014 Ultimo intervento - 5 nov 2014 alle 15:21
0
Grazie
Scusa hai ragione mi sono espresso male nell'esporre il problema
Faccio una sintesi del problema Connessione bluetooth
Sono alle prese con un progettino per controllare dei Led RGB secondo lo schema riportato in allegato


I dispositivi utilizzati sono:
Arduino Uno
Modulo bluetooth HC-06 Slave ops non trovo nessun documento relativo ai protocolli supportati
Smartphone Huawei y300 con modulo bluetooth versione 2.1 protocollo EDR profilo A2DP
Striscia Led rgb
Prima di fare i collegamenti ho alimentato il modulo bluetooth e tramite smartphone ho fatto l'accoppiamento tra i due dispositivi bluetooth
Ho scaricato diverse App sia realizzate tramite App Inventor sia direttamente da Google play ed ad ogni tentativo di connessione appare sempre il messaggio "errore 507 enable to connect is device turned On?"
Mentre tramite porta seriale ho effettuato il test AT Command con esito positivo.
Sono andato a rivedermi le proprietà dei due moduli Master/Slave ed ho notato le differenze
Bluetooth Y300 Enumeratore Bluetooth Microsoft
Bluetooth HC_06 "RFCOMM protocollo TDI"
Come dicevo nel messaggio precedente di questo "protocollo" (RFCOMM protocollo TDI) non ho capito nulla in rete c'è ben poco se non inviti a scaricare driver.
Spero di essermi fatto capire un po di più Grazie a tutti
Gianni Gallo
gbgallo1 2 Posti mercoledì 5 novembre 2014Data di registrazione mercoledì 5 novembre 2014 Ultimo intervento - 5 nov 2014 alle 16:02
Ancora scusa mi sono accorto che non ho risposto a tutte le tue domande
1) Il modulo HC-06 ha una connessione seriale costituita da 4 pin GND, VCC, RX,TX
2) Il modulo Bluetooth è collegato ad una board Arduino Uno
3) Il dispositivo non è provvisto di CD driver
4) l'accoppiamento avviene tramite immissione codice
5) il modulo non consente di attivare servizi ne di attivare la funzione OBEX

P.s da consultazioni lo smartphone utilizzato in vari tutorial dello stesso tipo utilizza la configurazione di default
Grazie a tutti
Saluti Gianni Gallo
n00r 22871 Posti giovedì 19 marzo 2009Data di registrazioneContribuenteStato venerdì 29 dicembre 2017 Ultimo intervento - 5 nov 2014 alle 17:27
mi spiace pensavo che fosse un semplice problema di connessione bluetooth tra PC e Cell... penso che tu sia più 'in gamba' in queste cose
spero che qualcuno possa esserti più utile.