Funzioni SE, E, O, NON Excel

Novembre 2016

In questa guida illustreremo come utilizzare le funzioni condizionali SE, E, O, NON su Excel. Ognuna di questa funzioni può essere utilizzata, come parte di una formula in una data cella, per confrontare i dati campioni, in un numero qualunque sia di colonne che di fogli di un file Excel.


Funzione condizionale SE Excel

La funzione SE permette di applicare una condizione ai propri dati per cui un risultato viene dato se la condizione è VERA e un altro risultato se la condizione è FALSA. La funzione SE può essere sia isolata, ossia quando una sola condizione viene applicata ai dati, o annidata, quando vengono applicati più criteri per generare un risultato VERO o FALSO.

Funzione SE isolata

Ecco alcuni esempi di una funzione SE isolata, dove è stata applicata una sola condizione per generare i risultati.

Se il grado della colonna A1 è maggiore o uguale a 19, allora visualizzare 20, altrimenti visualizzare A1:

=Se (A1> = 19, 20, A1).

Se il dato in A1 è uno “sconto”, allora sottrarre il 10%, oppure lasciare A1:

=A1 * SE (A1 = "Sconto"; 1-10%; 1)

Funzione SE annidata

In questi esempi di funzione logica SE annidata, sono state applicate più funzioni SE ai dati, generando così diverse risposte in base ai dati allocati nella costante dei dati. Si noterà infatti che ciascun criterio è separato da una virgola e che il numero di parentesi utilizzate alla fine della formula dipende dal numero di funzioni annidate all’interno:

Se il grado in A1 è maggiore di 12, visualizza “continua”; Se A1 è maggiore di 18, visualizza “molto bene”, altrimenti visualizza “sufficiente”. Ma se A1 è minore o uguale a 12, visualizza “da migliorare”.

=SE(A1>12;"continua" & SE(A1>18;"molto bene";"sufficiente");"da migliorare")

Oppure

=SE(A1<12;"da migliorare";SE(A1<18;"continua, sufficiente";"continua, molto bene"))

Se il grado in A1 è minore di 4, visualizza "nullo"; se A1 è compreso tra 4 e 8 allora visualizza “insufficiente”; se A1 è tra 8 e 12, visualizza “OK”; se A1 è tra 12 e 16, visualizza “Buono”; altrimenti visualizza “molto buono”.

=Se(A1<4;"nullo";SE(A1<8;"insufficiente";SE(A1<12;"OK";SE(A1<16;"buono";"molto buono"))))

La funzione E Excel

A differenza della funzione SE, che può funzionare isolata, con una data condizione, la funzione E verifica una pluralità di condizioni definite dall’utente, con risultato VERO, se tutte le condizioni dei dati sono conformi, e FALSO, se una condizione non risulta essere conforme.

Simile ad altre formule condizionali, è necessario conoscere come definire i propri risultati per VERO e FALSO. Ecco un esempio:

Mostra “La contessa!”, se tutte queste condizioni sono conformi: A2 (sex) = donna, B2 (stato) = sposata; C2 (coniuge) = conte e D2 (presenza) = presente, se no, visualizza “Ciao”

=SE(E(A2="donna"; B2="sposata"; C2="conte"; D2="presente"); "La contessa!"; "Ciao"):



Si avrà certamente notato che la formula inizia con la funzione SE. L’uso del SE segnala a Excel la presenza di una sorta di formula logica e dopo la funzione E ed i dati, raggruppati in una serie di parentesi tonde per isolare la funzione. Da notare anche, nella logica sopra espressa, che la condizione VERO ("La contessa!") precede la condizione di FALSO (“Ciao”). Entrambi i risultati sono infatti separati da un punto e virgola incluso in delle parentesi.

La funzione O Excel

La funzione O testa i termini definiti dall’utente e da come risultato VERO (o simili) se -al meno- una delle condizioni fissate dall’utente è conforme, mentre dà come risultato FALSO (o simili) se nessuna delle condizioni viene applicata. La funzione O è meno assoluta di quella precedente, ossia E. Eccone un esempio:

Visualizza “Pilota” se A3 contiene una delle seguenti condizioni: aereo, formula 1, moto; visualizza “Conducente” se A3 contiene auto o lavoro, in caso contrario visualizza “?”

=Se(O(A3="aereo"; A3="formula 1"; A3="motore");"Pilota"; SE(O(A3="auto";A3="lavoro");"Conducente";"?"))

La funzione NON su Excel

La funzione NON offre come risultato un valore opposto a quello logico o all’espressione fornita dall’utente.

La formula =SE(INT(A3)=A3;"intero"; "decimale") può anche essere scritta come =SE(NON(INT(A3)=A3); "decimale";"intero").

Allo stesso modo la formula =SE(A4<>"Italiano";"Straniero";"Europeo") è equivalente a =SE(NON(A4="Italiano");"Straniero";"Europeo").

Combinazioni funzioni Excel

Le funzioni E, O e NON sono spesso associate alla funzione SE. Ciò che risulta interessante (e gratificante) riguardo queste funzioni è che, insieme, possono essere usate per creare un diagramma di flusso, utile alla rappresentazione visiva dell’algoritmo di un problema. Per garantire i migliori risultati derivati dai dati e dalle condizioni imposte, assicurarsi di posizionare bene tutte le parentesi e i punti e virgola intrinsechi nelle funzioni di Excel.

Potrebbe anche interessarti :
Il documento intitolato « Funzioni SE, E, O, NON Excel » da CCM (it.ccm.net) è reso disponibile sotto i termini della licenza Creative Commons. È possibile copiare, modificare delle copie di questa pagina, nelle condizioni previste dalla licenza, finché questa nota appaia chiaramente.